Tutoriais de FreeCAD

Está página é dedicada a tutoriais pontuais, ou seja, para eventos mais específicos além do conhecimento básico de modelagem. Caso queira conhecimentos básicos pode acessar o fórum em que foi documentado os encontros do grupo de estudo para aprender FreeCAD. Aqui

Transportar um modelo 3D de uma placa desenvolvida no KiCAD para o FreeCAD.

  • Requisitos:
    • Possuir o external PCB para poder ler os arquivos gerados (Aprenda a instalar qualquer módulo externo em External_Workbenches)
    • Ter uma placa desenhada no KiCAD corretamente (Antes de tentar abrir no FreeCAD, abra sua placa no KiCAD Pcbnew e pressione Alt+3 para verificar se sua placa esta com um modelo 3D desejado);
  • Passos:

    1- Abra o o KiCAD, em seguida abra o PCBnew > File > Export > IDFv3 (salve o arquivo .emn em algum lugar de sua preferencia);
    file_export.png

    2- Abra o FreeCAD, crie um novo documento;

    3- Vá em File > Import, encontre o arquivo que você gerou e abra;

    4- Selecione como deseja abrir o arquivo .emn (qualquer uma das opções irá abrir o arquivo, contanto que você tenha o módulo PCB instalado);
    selecionar_PCB.png

    5- Pronto! Você tem agora a PCB, basta importar o photoprint de cada componentes e colocá-los em seus lugares com o Assembly2;

  • Pretendo estudar mais para descobrir como importar todos componentes já em suas posições;

Exportar arquivos 2D

Máquinas de corte a laser costumam exigir arquivos com figuras 2D, em formatos .jpg, e .dxf, por exemplo.

DXF

Para exportar a imagem devidamente, é necessário estar na Workbanch Draf e ajustar as preferências de exportação. Digamos que se deseje exportar para .dxf, primeiro é necessário ir em Editar --> Preferências --> Importar/Exportar --> .dxf e escolher as características desejadas. Para que isso seja possível, é importaren estar na workbach "Draft" e selecioanr as vistas desejadas.
Dicas:
  1. para que a vista correta seja exportada, é importante selecionar "Objetos de Projeto exportados juntamente com a direção de exibição atual", assim a imagem criada será a da vista atual.*
  2. O objeto exportado deve ser um sólido, não adianta ser um esboço. Por isso, a transformação em sólido deve ser levada em consideração. Caso se deseje exportar com diferentes camadas sólidos com furos, a sugestão é não gerar os furos como furos, buracos, pockets, é sugerido deixar na forma de sólido.
  3. *O objeto deve estar selecionado para que seja gerado o .dxf", caso contrário o arquivo será gerado com nenhum desenho dentro.

Essas informações são empíricas, não foi encontrado nenhum tutorial esclarecedor sobre o assunto. Um sugestão é acompanhar o tópico sobre o assunto no fórum oficial do site do FreeCAD.

SVG

A exportação em .svg é, a princípio, mais simples. Basta selecionar as peças que se deseja exportar e selecionar a opção Ficheiro-->Exportar, então deve-se escolher o formato de arquivo. Existem duas opções para .svg. Testes realizados pela equipe do CTA levaram a conclusão que a opção "Drawing (.svg, *.svgz, *.dxf)" não funciona corretamente, mesmo no workbanch "Drawing", e que a opção "Flatnned SVG (.svg)" funciona corretamente. Importante ressaltar que, diferentemente da exportação em dxf, não é possível escolher a vista de exportação. A exportação para svg SEMPRE ignorará as informações no eixo Z. Ou seja, não importa o que se faça, a vista exportada será sempre a XY. Não pareceu haver a necessidade de se estar em alguma workbanch específica para realizar a exportação;

Algumas peças que se tentou exportar apresentaram bastante problema, mas todos foram solucionados. Não houve coerência nenhuma nas solução encontradas. Seguem algumas dicas para se tentar resolver:
  • Fazer fusion (em part) nas peças;
  • Tirar o fusion (em part) da peças;
  • Deixar as peças em esboço, sem profundidade;
  • Deixar algumas peças em esboço e outras com profundidade;
  • Deixar as peças com diferentes profundidades, ou invertida em relação ao eixo.

Transformar arquivo .stl em .fcstd para editar no FreeCAD.

Aprendi isso seguindo esse tutorial - (Acesso em 27/04/2017);

Basta seguir os passos:

  • Abra o arquivo .STL que deseja editar;
  • Vá para o módulo Part;
  • Clique na aba Part e clique em Criar uma forma a partir de uma malha;
  • Determine a tolerância de costura de forma, ou deixe no padrão (0,1) que já é proposto;
  • Assim foi criado o objeto em uma malha(Como uma casca). Já pode excluir o .SLT (que está em verde na Arovre do projeto);
  • Com a peça selecionada, vá na aba Part e clique em "Converter para sólido" para dar volume a malha;
  • O objeto sólido foi criado, já pode excluir a malha e está concluído o processo;

Exportar para Gcode

Para isso é necessário ir para a bancada "Path". Selecione a peça desejada e clique em "Create a profile object around the surface", um ícone com uma presa fresando em verde o contorno externo de um peça azul. Ao clicar neste ícone, um arquivo .nc será gerado e irá aparecer na árvore de projetos. Existe um grande problema no código gerada. Ele criar o caminho, mas não cria um código completo, que defina unidades de medida, que ative o spindle, nem nenhuma outra função que não o trajeto da peça, não permite a definição do tamanho da ferramenta e do Z seguro de viagem. Existem muitos outros ícones e funções nesta bancada, mas poucos tutorias que esclareçam. Talvez exista a opção de configurar estes valores, mas não encontrei.

É preciso adicionar as seguintes linhas de comando:
  • No topo do código:

G21
G90
G94
F200.00
M03

  • Ao final do código:

G00 Z5.5000
G00 X0Y0
M05

O código é gerado considerando o sistema de coordenadas em que a peça foi desenhada, por isso partes desenhas nos eixos negativos também serão geradas nos eixos negativos da cnc. Geralmente as máquinas cnc não possuem eixos negativos, o que pode causar uma confusão. Além disso, algumas figuras que foram exportadas pela equipe do CTA não foram exportadas corretamente, estando em desacordo com a figura original.

file_export.png - file_export.png (233.7 kB) Renan Ritter Soares, 29/05/2017 21:36

selecionar_PCB.png - selecionar_PCB.png (13 kB) Renan Ritter Soares, 29/05/2017 21:36