Documentação de Uso da Fresadora PCI João-de-barro





Qual sua opinião?

  • Sua opinião é importante! Ao ler o manual, deixe seus comentários, críticas e sugestões no fórum Manual JB, eles são fundamentais para o aprimoramento do mesmo!

Avisos de segurança

  • A falta ou instalação inadequada de um fio terra poderá causar correntes elétricas fatais e/ou fogo. A máquina deve estar conectada a um fio terra devidamente testado. Nunca faça curto circuito de nenhum fusível, e use somente os fusíveis recomendados pelo fabricante.
  • É obrigatório o uso do aspirador com filtro HEPA (do inglês High Efficiency Particulate Arrestance) durante a usinagem. Gases e partículas levantadas pela usinagem podem ser nocivos à saúde.
  • A máquina é pesada e com partes móveis, uma só pessoa é incapaz de carregá-la, efetue a locomoção sempre com duas pessoas e com as partes fixas, como vieram na embalagem. Não descarte as peças de fixação de partes móveis.
  • Garanta-se de que apenas uma pessoa opera ou repara a máquina, para evitar que algum comando seja acionado acidentalmente, causando danos físicos ao usuário.
  • A maioria das brocas possuem cantos afiados, tome cuidado para não se cortar com as mesmas.
  • Instale a máquina em um local firme, sólido e plano, impossibilitando-a de se mover sozinha devido à vibração ou gravidade.
  • Não utilize outras chaves de parafuso hexagonal ou parafusos senão os providos pelo fabricante, caso contrário peças podem ser danificadas. Caso danifique tais peças ou ferramentas, contatar o fabricante para reposição.
  • Mantenha a área de trabalho interna da máquina limpa usando um pincel. Nunca use jato de ar comprimido para limpeza.
  • Certifique-se de tirar a máquina da tomada antes de realizar qualquer manutenção na máquina.
  • A máquina é bastante ruidosa, use abafadores auriculares. A longa exposição sem o devido equipamento de proteção pode causar danos à audição.
  • Nunca bloqueie o acesso ao botão de emergência, o mesmo é fundamental para a segurança do usuário.
  • Só pessoas habilitadas e devidamente treinadas podem realizar manutenção na máquina.

Mais informações de segurança na pagina Avisos de segurança.



Instalação do software

FlatCAM

FlatCAM está sob a licença MIT License (MIT)
Este programa será usado para gerar o arquivo de código G.

LINUX

  • Use o seguinte comando no Terminal para baixar os arquivos do programa:
  • Este comando criará uma pasta “flatcam” no diretório atual e copiará os arquivos necessários para executar o programa
  • Para isto, você precisa antes instalar o programa Git em seu computador. Para fazer isto, aplique a seguinte sequência de comandos:
    • sudo apt-get update
    • sudo apt-get install git
  • Pelo Terminal entre na pasta “flatcam” dentro do diretório em que você estava quando aplicou o comando “git clone...”
  • Instale as dependências necessárias para o funcionamento do programa com os seguintes comandos:
    • sudo bash setup_ubuntu.sh
    • sudo bash upgrade_geos.sh
  • Após a instalação destas dependências, você já pode iniciar o programa. Pelo terminal, entre na pasta “flatcam” e execute o comando:
    • python FlatCAM.py

WINDOWS

  • Para baixar um executável que instala o programa, acesse https://bitbucket.org/jpcgt/flatcam/downloads
  • Baixe o arquivo FlatCAM-Win32-8.4 Windows (executável) para baixar o instalador
  • Instale o programa pelo executável recém-baixado
  • Em uma parte da instalação, aparecerá uma caixa de marcação escrito Create a desktop icon selecione a mesma para criar um atalho na área de trabalho, pois facilita o processo de execução do programa
  • Ao fim desta instalação, o programa está pronto para funcionar. Use o atalho criado na sua área de trabalho para iniciar o programa.

Universal G-code Sender

Universal G-code Sender está sob a licença GNU GENERAL PUBLIC LICENSE, Versão 3.
Este programa será usado para controlar e mandar arquivos de código G para a máquina.

LINUX

  • Acesse https://github.com/winder/Universal-G-Code-Sender
  • Baixe o arquivo UniversalGcodeSender-v1.0.9.zip
  • Descompacte o arquivo UniversalGcodeSender-v1.0.9.zip
  • Para rodar o programa, pelo Terminal, entre na pasta descompactada (UniversalGcodeSender-v1.0.9) e execute o comando:
    • java -jar UniversalGcodeSender.jar
  • Caso este comando não funcione, talvez seja necessário instalar um pacote com Java com o seguinte comando:
    • sudo apt-get install default-jre

WINDOWS

  • Acesse https://github.com/winder/Universal-G-Code-Sender
  • Baixe o arquivo UniversalGcodeSender-v1.0.9.zip
  • Descompacte o arquivo UniversalGcodeSender-v1.0.9.zip
  • Para rodar o programa, execute o arquivo start-windows.bat localizado na pasta recém-descompactada.

ATENÇÃO: Durante a operação da máquina pelo software Universal G-code Sender, não abra o visualizador. Caso entre no visualizador, um erro ocorrerá, pois a máquina não suporta tal operação e o software falhará. O processo em andamento terá de ser interrompido e o programa reiniciado.



Usinagem de placas de circuito impresso

Antes de aprender a utilizar os programas de controle e de geração de código G (G-code e FlatCAM), é necessário adquirir conhecimento sobre as ferramentas utilizadas para a usinagem das PCI (Placas de circuito impresso).

FERRAMENTAS DE USINAGEM

  • FRESAS DE TOPO: A fresa comum, utilizada para tirar uma camada da superfície do material. A largura de retirada do material é uniforme e independe da profundidade em relação à superfície. Para fresas finas (menos de 1mm de diâmetro), recomenda-se uma velocidade avanço de no mínimo 180 mm/s e no máximo 500 mm/s. Para fresas maiores, um máximo de 750 mm/s. Teste velocidades baixas e vá aumentando.
  • BROCAS: Ferramenta bastante comum e barata, utilizada para fazer furos de diversos diâmetros. Brocas finas (entre 0.8 e 1.2 mm) podem usinar a 700 mm/s. Brocas com menos de 0.8 mm e com mais de 1.2 mm devem ir mais devagar, a no máximo 400 mm/s.
  • FRESAS DE RECORTE: Ferramenta parecida com a fresa de topo, mas com várias ranhuras ao longo da superfície de corte. Usada para remover camadas mais grossas de material, porém com acabamento bem pior. Recomenda-se usar esta ferramenta somente para recortar as bordas da placa, pois o acabamento é de baixa qualidade. Não há problema se não tiver esta ferramenta, pois a fresa de topo consegue recortar a placa também, graças a um recurso do FlatCAM. Como retira bastante material, deve ir mais devagar que as demais ferramentas. Recortando uma placa de 2.5 mm, recomenda-se a utilizar velocidade não superior a 150 mm/s.
  • GRAVURA (carving): Ferramenta utilizada para fazer pequenas marcações ou isolamento de trilhas. A largura de usinagem depende da profundidade em relação à superfície. Geralmente mais robustas que as fresas de topo, podem suportar altas velocidades facilmente. Recomenda-se não passar de 800 mm/s.

FIXAÇÃO DA PLACA VIRGEM NA MESA

  • Antes de fixar a placa virgem na mesa, coloque-a em cima da mesa de sacrifício, verificando se a mesma está plana. Desentorte manualmente a placa para aumentar a qualidade da usinagem. Dependendo de quão torta estiver a placa, ela poderá ficar solta na mesa, impossibilitando a usinagem.
  • Depois de desentortar a placa, aplique fita dupla face na camada inferior a que será usinada em aproximadamente 50% da superfície, com bastante cuidado, evitando a formação de bolhas entre a fica e a placa. A formação de bolhas pode alterar a qualidade final da usinagem.
  • Ao grudar a placa na mesa, certifique-se de que a mesma encontra-se alinhada com o limite de cada eixo de usinagem. Você pode ver bem qual o limite de usinagem colocando a máquina na posição (X0 Y0), (X149 Y199), (X0 Y199) e (X149 Y0). Estes comandos serão explicados adiante, na parte de comandos do Universal G-code Sender.

ALINHAMENTO PARA PLACAS DUPLA-FACE

  • Junto com a máquina você receberá vários pinos de 1 mm de diâmetro. Estes pinos serão utilizados para o alinhamento de placas de dupla face.
  • Dentro do programa KiCAD (ou seu CAD de preferência) crie dois furos individuais e de um diâmetro qualquer, com um diâmetro diferente de todos os outros furos da placa, para poder identificá-los no programa FlatCAM em seguida. Os furos devem estar exatamente no eixo central da placa, paralelos ao eixo x ou y. Isto está melhor explicado nas seções KiCAD e FlatCAM
  • Após terminar um lado da placa, retire a mesma da mesa. Também retire a fita adesiva dupla face da camada a ser usinada
  • Aplique a fita dupla face na camada pronta
  • Faça pequenos buracos na fita aonde estão os furos de alinhamento, para facilitar o encaixe posterior
  • Coloque os pinos de alinhamento nos buracos de alinhamento feitos na mesa de sacrifício
  • Encaixe, vagarosamente e com bastante cuidado, a placa através dos pinos de alinhamento
  • Retire os pinos antes de começar a segunda camada
  • ATENÇÃO: A retirada dos pinos é muito importante, pois a não remoção poderá levar à destruição da broca e danos na máquina.

PREPARAÇÃO FINAL DA PLACA

Quando terminar de usinar a placa, é bem provável que restem rebarbas nos cantos das trilhas. Para removê-las, passe uma lixa levemente e uniformemente até que as mesmas sejam removidas. Passe uma esponja de aço pouco agressiva para deixar a superfície mais lisa.

Para evitar a oxidação das camadas de cobre, é recomendado passar uma fina camada de estanho sobre toda a superfície de cobre. Para tal, aplique uma fina camada de pasta de solda sobre as trilhas, pois a mesma aumenta a fluidez do estanho. Com um ferro de solda, aplique o estanho sobre as superfícies de cobre. Sem a pasta de solda este processo é bastante trabalhoso.

CALIBRAÇÃO DA MÁQUINA

O comando “$H” executa o processo que zera o posicionamento da máquina. Ou seja, alinha o posicionamento virtual de cada eixo com o posicionamento verdadeiro através de limites de curso instalados em cada eixo. Isto é necessário pois o programa de controle não tem informação sobre aonde realmente está posicionada a broca. O programa sabe a posição através de cálculos, mas não através de sensores. Mesmo assim, a precisão contínua sendo bastante alta, pois processos de até 5 horas de usinagem em alta velocidade foram feitos com perfeição sem executar a calibração.



KiCAD

FUROS DE ALINHAMENTO PARA DUPLA FACE

  • Quando quiser fazer uma PCI com duas camadas de circuito, terá que adicionar dois furos de alinhamento personalizados em seu desenho CAD. Este procedimento será mostrado através do CAD que utilizamos e incentivamos o uso, o KiCAD.
  • Será necessário fazer o espelhamento para a parte de baixo do circuito (parte oposta aos componentes). O espelhamento será feito pelo FlatCAM, mas alguns objetos têm de ser feitos no KiCAD para o espelhamento funcionar corretamente. Siga os passos a seguir para tal:
  • Utilizando a ferramenta Régua, meça os limites x e y do seu projeto (largura e altura)
  • Calcule a metade do tamanho x ou y do circuito e marque a metade do eixo escolhido com a mesma ferramenta. Caso tenha feito uma borda personalizada, utilize as extremidades da mesma como base para as medidas
  • Adicione dois furos de tamanho personalizado nas extremidades da placa, dentro da borda (adiante, bordas personalizadas serão explicadas) e no eixo de simetria da placa
  • Para adicionar os furos de tamanho personalizado, adicione o footprint Pin Headers > Pin_Header_Straight_1x01
  • Com o cursor sobre o furo do footprint adicionado, aperte E e selecione Pad
  • Altere o diâmetro para um tamanho qualquer, mas diferente dos demais furos da placa, pois este furo terá de ser bem mais profundo que os demais para criar um suporte para os pinos de alinhamento
  • Selecione alguma camada não utilizada por nenhum outro objeto do projeto, e crie um traço que vai de um furo de alinhamento ao outro. Este objeto será utilizado como base para espelhamento de camadas no FlatCAM, procedimento explicado mais adiante

BORDAS PERSONALIZADAS

  • Para criar uma borda personalizada selecione a camada Edge.Cuts
  • Com as ferramentas de desenho, crie um desenho qualquer para determinar a borda da placa.
  • Para que o FlatCAM consiga criar uma geometria de corte, você deverá preencher o desenho com a ferramenta de área preenchida (Add filled zones)
  • O desenho pode ter vãos, mas o visualizador 3D do KiCAD não os aceitará. Isto não é um problema para a manufaturação da placa, somente para sua visualização virtual
  • Para resolver este problema, a camada Edge.Cuts deve estar sem nenhum vão no desenho. Você pode utilizar outra camada sem objetos para criar o desenho de recorte real, e mante a Edge.Cuts somente para criar uma borda para visualização em 3D. Recomenda-se o uso da camada Margin
  • DICA: Mais adiante, para prevenir uma parte ainda não coberta pelo FlatCAM, recomenda-se colocar trilhas de cobre separadas, o menor possível, nos cantos da borda da placa. Isto serve para o software ter algum pedacinho para detectar até onde deve ir na remoção de todo o cobre da placa, como mostra uma imagem na página 22.

EXPORTAÇÃO DE ARQUIVOS DO KiCAD

  • Antes de exportar os arquivos, é necessário configurar a origem da grade:
  • Posicione a origem no extremo esquerdo inferior do seu desenho, através da ferramenta Place>Grid Origin e depois Place>Drill and Place Offset. Utilize o cursor de tela completa para facilitar este procedimento. Este passo é fundamental posteriormente para o manejo de desenhos no FlatCAM

exportação de arquivos kicad


  1. Para iniciar a exportação, clique no botão Plot, na aba superior da interface
  2. Selecione as camadas que deseja exportar
  3. Na aba Options selecione Use auxiliary axis as origin
  4. Na aba Plot format selecione Gerber
  5. Na aba Output directory você pode usar um diretório específico para exportar os arquivos
  6. Clique no botão Plot. Isto exportará as geometrias das camadas selecionadas
  7. Os arquivos exportados estarão em formato .gbr

exportação de gbr kicad


  1. Para exportar os furos, clique no botão Generate drill file
  2. Na aba Drill Units selecione Millimeters
  3. Na aba Drill Map File Format selecione PostScript
  4. Na aba Drill origin selecione Auxiliary axis
  5. No campo Output directory você pode usar um diretório específico para exportar os arquivos
  6. Clique no botão Drill File para exportar os furos
  7. O arquivo exportado estará em formato .drl

exportação de drl kicad



FlatCAM

CONFIGURAÇÃO INICIAL

  • A primeira vez que iniciar o programa, deverá alterar a configuração para milímetros, pois o programa original está em polegadas. Abra o programa. Na aba Options marque mm. Então vá no menu File>Save Defaults para guardar as configurações. Feche o programa e abra novamente para aplicar as alterações.

configuracao inicial flatcam

IMPORTANDO ARQUIVOS

  • Para importar os arquivos de furo (.drl), vá no menu File>Open Excellon. Para importar os demais arquivos, vá em File>Open Gerber.
  • Após importar todos os arquivos, verá algo como abaixo. Poderão existir menos ou mais camadas dependendo do seu projeto.

  • Caso tenha exportado corretamente os arquivos do KiCAD, deverá observar que nenhum ponto de nenhuma camada ultrapassa os eixos X e Y.
  • Por didática alterei a maneira de visualização da camada Edge.Cuts e F.Cu para somente borda. Você pode fazer o mesmo com qualquer camada, selecionando a mesma, indo na aba Selected e desmarcando o campo Solid.
  • Explicando cada camada:
  • A camada B.Cu é a camada de trilhas de cobre que está atrás dos componentes.
  • A camada F.Cu é a camada de trilhas de cobre que está na frente da placa, junto com os componentes.
  • A camada Eco2.User é um traço grosso que vai de um furo de alinhamento ao outro. Serve para marcar o centro de espelhamento para a usinagem de duas camadas.
  • A camada Edge.Cuts é um desenho preenchido que marca a borda da PCI.
  • O arquivo .drl contém a descrição de cada furo.

REPOSICIONAMENTO DE CAMADAS

  • Esta etapa fará com que as camadas sejam afastadas dos eixos X e Y, gerando espaço para as ferramentas fazerem seu trabalho. Todas as camadas deverão ser reposicionadas igualmente. Para tal, com uma camada selecionada, vá para o menu Selected. Desça a barra de rolagem até o final. No campo Offset>Vector será colocado um vetor (X,Y) que moverá toda a camada. Um vetor (2.5,2.5) geralmente é o suficiente. Clique em Offset para mover a camada. Copie e cole este vetor e repita o procedimento para todas as camadas. Você pode usar esta ferramenta para fazer diversas PCI na mesma usinagem, basta importar mais arquivos e reposicioná-los corretamente.
  • Abaixo, o antes e o depois do procedimento.

p>.

ESPELHAMENTO DE CAMADAS

  • Esta etapa é fundamental para qualquer projeto. Como ao projetar o circuito a placa é vista de cima, as camadas inferiores deverão ser espelhadas, pois serão usinadas com a placa virgem de ponta cabeça. Recomenda-se fazer os furos antes de tudo, para evitar que uma broca entre em uma parte com desnível gerado por outra usinagem. Assim sendo, os furos também terão de ser espelhados. Caso também resolva fazer o recorte antes de ir para a segunda camada de cobre, a mesma também terá de ser espelhada.
  • Para esta etapa o objeto da camada Eco2.User é usado. Um traço que vai de um furo de alinhamento ao outro.
  • Entre na aba Tool, ao lado de Selected e Options
  • Na aba superior Tool (destacada em vermelho, ao lado de Drawing), selecione Double-Sided PCB Tool.

Obs.: É possível também utilizar a camada Edge.Cuts para o espelhamento, contanto que ela seja simétrica em pelo menos um dos eixos. Nesse caso, basta usar como Point/Box a camada Edge.Cuts e espelhar no eixo em que a placa for simétrica.

  • Descrição da ferramenta Double-Sided PCB Tool
  • Bottom Layer: Camada a ser espelhada.
  • Mirror Axis: A qual eixo cartesiano o eixo de espelhamento é paralelo.
  • Axis Location: Define se o espelhamento será o eixo central da própria camada, ou ao longo do eixo central de uma camada selecionada.
  • Point/Box: Objeto cujo eixo central será usado como eixo de espelhamento. Deverá ser usado o objeto que é um traço de um furo de alinhamento ao outro.
    Os demais campos não serão utilizados.

Selecione, uma por vez, as camadas que serão espelhadas, depois clique em Mirror Object para efetuar o espelhamento.

Após o espelhamento correto, o projeto mudará para algo assim. Compare com o projeto quando recém exportado 3 páginas atrás.

ATENÇÃO: Para uma placa de simples-face o espelhamento também é necessário, pois será usada a camada oposta à camada que receberá os componentes. Use qualquer objeto como base de espelhamento ou defina um ponto marcando a opção Point e inserindo o ponto pelo qual passará o eixo de espelhamento em Point/Box.

FUROS

Cada diâmetro de furo deverá ter um arquivo de perfuração diferente. Você pode aglutinar furos parecidos em um arquivo só, como furos de 0.98, 1.01 e 1.0 mm. Se usinar furos de 1.1 mm com a broca de 1 mm, corre o risco de um componente não encaixar direito na hora da soldagem. Não é um erro grave, pois o buraco pode ser alargado manualmente. Aglutinar diâmetros diferentes poupa tempo, pois cada broca utilizada deverá ser trocada manualmente.

Para gerar os arquivos de furos selecione a camada .drl com duplo clique. Isto entrará no menu Selected. Na seção Tools, ao clicar em #, os diferentes diâmetros de buracos serão alinhados em ordem crescente ou decrescente. Selecione os diâmetros que quer usinar, segurando a tecla Ctrl para selecionar mais que um diâmetro (caso selecione vários diâmetros, eles serão usinados juntos e com a mesma broca). Deverá clicar nos números ordinais, e não nos diâmetros, para selecioná-los.

Na seção Create CNC Job, serão selecionadas as características da usinagem dos furos.
  • Cut Z: determina a que altura do eixo Z a ferramenta irá furar (profundidade do furo).
  • Travel Z: determina a que altura do eixo Z o bocal ficará ao alternar entre as posições dos furos, ou seja, a altura de viagem, em tradução literal (espaço acima da placa de usinagem).
  • Feed Rate: determina a velocidade de avanço em mm/s. (alterei)
    Os demais campos desta seção não são utilizados e devem ficar em branco.

Quando preencher corretamente todos os campos, clique em Generate. Isto criará um arquivo para fazer os furos selecionados, já em código G. Faça o mesmo procedimento para os demais grupos de furos que quiser.

Faça os furos de alinhamento separadamente e utilize profundidade de 3 mm para furá-los, pois terão de suportar os pinos de alinhamento. Este é o motivo pelo qual estes foram alterados no KiCAD: para identificá-los facilmente nesta etapa. A broca deve ser de 1 mm de diâmetro.

No caso desta captura de tela, estão selecionados os diâmetros 1.0, 1.001 e 1.016 mm. Desta maneira, será usada uma broca para fazer buracos de 1 mm no lugar destes três diâmetros diferentes. Os campos estão preenchidos para a antiga versão da máquina.

Se você der um clique duplo no objeto criado, que tem o formato .drl_cnc, poderá alterar o diâmetro de visualização no campo Tool dia e então conseguirá ver os caminhos que a máquina percorrerá e conferir o tamanho dos furos que serão feitos.

TRILHAS

Esta etapa é separada em duas partes: a isolação das trilhas e a remoção de cobre no restante da placa. A primeira etapa cria as trilhas, já deixando possível a soldagem e uso do circuito na maioria dos casos. A segunda etapa retira todo o cobre remanescente na placa, dando um acabamento mais profissional.

ISOLAMENTO

  • Dê um duplo clique em alguma camada de trilhas para entrar no menu Gerber Object.
  • Na subseção Isolation Routing, há os seguintes campos a serem preenchidos:
  • Tool dia: Diâmetro da fresa a ser usada.
  • Width (# passes): Número de vezes que as trilhas serão contornadas, ou número de passes.
  • Pass overlap: O quanto cada passe se sobrepõe ao anterior. Se 0, um ficará exatamente do lado do anterior, sem folga nem sobreposição. Se 1, todos os passes criados ficarão igual ao primeiro. Recomenda-se um valor entre 0.1 e 0.7. Quanto mais finas e encostadas entre si as trilhas do circuito, maior deve ser este valor.
  • Combine Passes: Caso marcado, junta os diferentes passes em um único arquivo. Caso queira fazer cada passe em uma altura diferente, desmarque esta opção.
  • Para gerar a geometria, clique em Generate Geometry. As alturas de operação serão definidas em outra parte.

As figuras abaixo ajudam a explicar esta parte e seus parâmetros.

p>.

Os traços vermelhos mostram o centro de onde passará a broca. As duas imagens usaram os parâmetros Tool dia=0.5 e Width (# passes)=2. Na figura à esquerda foi usado o parâmetro Pass overlap=0.3. As partes destacadas em azul, adicionadas por edição de imagem, mostram que a segunda passada não retiraria uma parte do cobre entre as trilhas, reduzindo a qualidade do acabamento. Caso estes pedaços não sejam removidos, terão de ser removidos manualmente depois. Na figura à direita o parâmetro usado foi Pass overlap=0.8. A segunda passada agora passa novamente entre as trilhas, mas retira muito pouco.

O parâmetro ideal Pass overlap seria em torno de 0.4 e 0.5 para este circuito. Altere este parâmetro até que os traços que passam entre as trilhas estejam próximos.

Caso use 3 passadas, não há tanto problema em deixar que a terceira camada não passe dentre todas as brechas. Se a primeira não passar, há um erro no circuito, pois a broca é maior que o menor espaçamento entre trilhas, impossibilitando o processo de isolamento. Para consertar isto, refaça o circuito e reposicione as trilhas usando um espaçamento maior entre as trilhas. Ou consiga uma fresa menor.

REMOÇÃO DO EXCESSO DE COBRE

Esta etapa serve para retirar todo o cobre remanescente após o isolamento de trilhas. Porém, o problema que ocorre no final da parte sobre isolamento de trilhas não é solucionado por este método.

É altamente recomendado executar esta etapa se quiser deixar sua placa mais bem acabada, se estiver usinando um circuito analógio ou se existirem componentes SMD no circuito.

O processo pode ser bastante demorado, chegando a ultrapassar uma hora de usinagem, mesmo em velocidades altas.

Para iniciar, dê um clique duplo sobre a camada de cobre que quer remover.

Será usada a ferramenta Non-copper regions. Esta ferramenta criará uma geometria que contorna todas as trilhas e um retângulo ao redor de toda a placa. O campo Boundary Margin define qual a distância entre o retângulo externo e as trilhas em milímetros. O marcador Rounded corners define se este retângulo terá os cantos arredondados ou não. Se for usar uma fresa de 1.6mm de diâmetro, coloque 1.8 em Boundary Margin, para ter uma folga. Clique em Generate Geometry. O resultado será o seguinte:

Então, volte e selecione o objeto recém criado, que possui o formato .gbr_noncopper, e vá para Selected. Na seção Paint Area existem campos idênticos aos preenchidos para gerar o isolamento das trilhas, exceto o campo Margin, que define a distância a ser mantida das trilhas. Os dois marcadores em Method determinam dois métodos diferentes de remoção. Standard fará algo parecido com o isolamento de trilhas, e Seed-based criará círculos que removem mais homogeneamente o cobre. Para criar a próxima geometria clique em Generate e depois em qualquer área dentro do retângulo. O resultado deste clique pode demorar a aparecer, e está na próxima página.

Este método tem uma falha. Caso o recorte da placa vá além desta região demarcada, a parte fora desta região continuará com cobre. Isto pode ser resolvido adicionando minúsculas trilhas em cada camada de cobre, no KiCAD, perto dos cantos da borda, como mostra abaixo.

A parte em cinza escuro é a geometria que define a borda da placa, e o traço amarelo dentro da caixa rosa indica um pequeno traço de cobre nas duas camadas.

RECORTE

PADRÃO

Utiliza uma ferramenta do FlatCAM para gerar uma borda simples. Esta ferramenta simples cria um retângulo ao redor do circuito, que será a borda da placa. Este método quase nunca funciona para placas dupla face.

Selecione com clique duplo a camada de trilhas. A seção utilizada para criar o recorte é Board cutout.

Tool dia: diâmetro da fresa que será utilizada para o recorte. Caso use uma fresa de topo existe um detalhe adicional que será descrito na parte de exportação de arquivos do FlatCAM.

Margin: a distância que ficará entre as trilhas e a margem da placa. Ele calcula automaticamente, junto com o diâmetro da fresa, para deixar a margem no tamanho desejado.

Gap size: esta ferramenta irá deixar dois ou quatro pedaços conectados entre o circuito e a placa virgem, para facilitar a remoção da mesma da mesa de sacrifício. Este campo define a largura destas conexões. Defina 0 caso não queira estas.

Gaps: define a quantidade e/ou posição das conexões. 2 (T/B) deixa duas conexões: uma em cima e outra em baixo. 2 (L/R) deixa duas conexões: uma na direita e outra na esquerda. 4 deixa quatro conexões: uma em cada lado.

Clique em Generate Geometry para criar a geometria de borda padrão. Abaixo uma imagem do resultado:

Porém, é possível ver, como contorno em preto, como deveria ser a borda para que o circuito dupla-face fosse usinado corretamente. Para isto serve o procedimento de recorte personalizado.

PERSONALIZADO

Utiliza geometrias criadas no KiCAD para fazer um recorte em qualquer formato. Geralmente circuitos de duas camadas necessitam deste procedimento, pois as duas camadas não necessariamente estão contidas na mesma borda criada pelo FlatCAM no método padrão.

Selecione com duplo-clique o objeto com a geometria da borda personalizada feia no KiCAD.

Este objeto será tratado da mesma maneira que as trilhas, usando a seção Isolation Routing. Os parâmetros usados são os mesmos.

Selecione o diâmetro da ferramenta de corte, defina Width (# passes)=1, o Pass overlap não faz diferença. Desta maneira, a borda será contornada somente uma vez.

Obs.: Nesse processo, o FlatCAM trata a camada Edge.Cuts como uma trilha, ou seja, contorna ela.
Para evitar que a fresa de recorte corte partes do circuito, é necessário ter uma distância mínima
entre o circuito propriamente dito e limite da placa pela Edge.Cuts. Essa distância deve ser maior
ou igual ao diâmetro da ferramenta utilizada no recorte
.
No caso da imagem abaixo, utilizamos uma fresa 2mm para recorte da placa,
portanto essa será a distância mínima do circuito para os limites da Edge.Cuts


EXPORTAÇÃO DE ARQUIVOS

Neste ponto, algumas geometrias ainda precisam da geração do código-G. Somente os furos já estão prontos para exportação.

GERAÇÃO DE CÓDIGO-G

Há três tipos de arquivo que necessitam de maiores especificações para gerar o código-G. Recorte, isolamento de trilhas e retirada do excesso de cobre.

Cada camada de cobre terá um isolamento de trilhas e uma remoção de excesso de cobre.

Para começar a exportação, selecione com duplo-clique um dos objetos em questão.

Na aba Selected e na seção Create a CNC Job existem os seguintes campos a serem preenchidos, que serão separados pelo tipo de geometria a ser gerada:

Isolamento de trilhas e remoção de excesso de cobre:

Cut Z: altura de corte. Esta deve estar a uma profundidade de mais de 0.05 mm abaixo da superfície que contém cobre. Recomenda-se ajustar esre parâmetro para que fique 0.1 mm de profundidade na placa usando fresas de topo. Outras pontas têm parâmetros variáveis.
Travel Z: altura de viagem. Altura que ficará a broca ao trocar entre um e outro ponto de usinagem. Recomenda-se ajustar este parâmetro para que fique ao menos 1 mm acima da superfície.
Feed Rate: velocidade com que a operação será realizada. Depende da ferramenta e da profundidade que serão usadas. Estes detalhes estão na descrição das ferramentas de usinagem, na página 8.
Tool dia: diâmetro da ferramenta que será usada na usinagem.

Recorte padrão ou personalizado:

Cut Z: ajustar parâmetro para que a broca encoste na mesa de sacrifício e corte toda a placa de uma vez. Se for usar uma fresa de topo para fazer o recorte, a velocidade máxima deve ser 70 mm/s. Recomenda-se testar antes com uma velocidade mais baixa, mas não inferior a 50.
Travel Z: ajustar para que a broca passe no mínimo 1 milímetro acima da superfície de cobre.

Clique em Generate para gerar o arquivo de código-G. Os arquivos de código-G possuem o desenho de uma broca. Para exportar cada um deles, dê um duplo-clique e o menu CNC Job Object aparecerá. O botão Export G-Code executará a função de exportação.

Descrição de cada parâmetro:

  • Camada: o número da camada em que a operação deverá ser feita (01 ou 02). Mesmo em uma PCI de simples-face este campo é obrigatório, e será 01.
  • Ferramenta: as ferramentas mais comuns de usinagem. Estas podem ser:
    • BROCA: a broca comum, como diz o nome.
    • FRESAT: fresa de topo comum.
    • FRESARC: fresa de recorte, também conhecida como lima cilíndrica.
    • VCUT: fresa de corte em V sofisticada, geralmente possui um revestimento preto na ponta.
    • V *: ponta de corte em V comum.
    • PIRAMIDAL *: como diz o nome.
    • (*) deve ser substituído pelo ângulo de abertura da ponta, em graus.
  • Operação: as operações já definidas são: LIMPA (remove o excesso de cobre), ISOLA (isolamento das trilhas), RECORTA (recorte da borda), AFURA (furo de alinhamento), FURA (demais operações de furação). Há uma operação a ser definida, mas já com nome pronto: GRAVA (faz gravuras, textos e pequenos detalhes).
  • Corte: altura de corte (Cut Z) em mm/10 (milímetro dividido por 10, para evitar o uso de pontos). Neste campo, 50 significa 5 mm.
  • Viagem: altura de viagem (Travel Z) em mm/10.
  • Velocidade: velocidade de avanço (Feed Rate) em mm/s.
  • Diâmetro: diâmetro do corte/furo planejado.
  • Calibração: altura em que deve ser zerada a ferramenta em mm/10. A letra M depois indica que deve ser zerada na mesa de sacrifício. A letra P que deve ser zerada na altura da superfície de cobre.

Nomeação padrão de arquivos

Para manter a uniformidade de diversos projetos e sua organização, também como facilitar a usinagem posteriormente, está definido um modelo padrão para nomes de arquivos de código-G, como segue abaixo:

camada_ferramenta_operação_corte_viagem_velocidade_diâmetro_calibração.ngc



Universal G-code Sender

CONFIGURAÇÃO INICIAL

Ao iniciar o programa pela primeira vez, certifique-se de que o campo Firmware está marcado com a opção GRBL, o firmware da máquina. O campo Baud indica a frequência de operação do Arduino que controla a máquina, que deve ser 115200.

Na aba Machine Control, certifique-se de que a caixa de marcação milimeters está marcada, e não inches.

CONTROLE DA MÁQUINA

Para conectar a máquina ao computador, conecte o cabo USB ao mesmo, preferencialmente no painel traseiro da CPU. Caso tenha aberto o programa antes de conectar a máquina, clique no botão Atualizar (seta rotatória) e então selecione uma porta de entrada na aba Port. Ao conectar pelo botão Open, o programa pedirá para que mande o comando $H, que efetua a calibração por fim de curso da máquina. Este processo é automático. Caso ela não inicie, feche a conexão pelo botão Close e selecione outra porta no menu Port.

Para saber mais sobre todos os comandos da máquina, a seção Comandos GRBL mostra todos os comandos e como usá-los. Os mais básicos são:

M3: liga o spindle
M5: desliga o spindle
$H: efetua a calibração da máquina
X*: posiciona a máquina na coordenada * do eixo X
Y*: posiciona a máquina na coordenada * do eixo Y
Z*: posiciona a máquina na coordenada * do eixo Z
G0: faz os movimentos em todos os eixos da maneira mais rápida possível
G1: faz os movimentos em todos os eixos com a última velocidade mandada para a máquina
F*: determina a velocidade dos movimentos para a velocidade * em mm/s

MANDANDO ARQUIVOS

Para mandar arquivos para a fresadora basta entrar no menu File Mode, clicar em Browse, selecionar o arquivo a ser mandado e clicad no botão Send,

O botão Pause faz com que a máquina pare o processo, mas possa continuar depois. O botão Cancel cancela o procedimento.

Nenhuma configuração é necessária neste momento, pois todas as configurações já estão nos arquivos exportados pelo FlatCAM.

Apenas o posicionamento correto das ferramentas é necessário antes de mandar os arquivos.

POSICIONAMENTO DAS FERRAMENTAS DE USINAGEM

Esta etapa deverá ser baseada no nome dos arquivos .ngc que serão mandados para o Universal G-code Sender, por isto é bastante importante a nomeação correta dos arquivos.

Todas as ferramentas possuem o mesmo procedimento de posicionamento na versão 1 da máquina, e que funciona para todas as ferramentas, menos as brocas, na versão 2 da fresadora. Na versão 2 há uma ferramenta para ajustar a altura da broca.

Para posicionar uma ferramenta:

  • No nome do arquivo, a parte final dirá como fazer o alinhamento
  • Suponhamos que seja 12P
  • Primeiro, afrouxe o parafuso do eicaixe de brocas
  • Coloque a ferramenta até o limitador da mesma encostar no encaixe
  • Primeiro mande um comando para que a ferramenta vá ao limite superior do eixo Z, deixando espaço suficiente para a ferramenta se mover para os lados sem bater na placa
  • Através de comandos posicione a ferramenta acima da placa que será usinada, em uma parte com cobre
  • Com mais um comando, posicione a máquina em Z12
  • Solte o parafuso do encaixe e empurre a ferramenta para baixo, até encostar na placa

A máquina agora está pronta para receber os arquivos e usinar.

Para fixar a placa na mesa de sacrifício, use fita dupla-face comum. Cubra ao menos 50% da superfície, sem sobrepor nenhuma tira de fita e evitando bolhas entre a fita e a placa.

Para remover a placa da mesa de sacrifício, utilize uma espátula e faça o mesmo com bastante cuidado para não estragar o cobre. Ao remover a placa usinada nos dois lados, ter cuidado especial, para não danificar as trilhas já prontas.

ATENÇÃO: Leia no apêndice a ordem correta para seguir todas as etapas descritas neste manual.

kicad0.png - exportação de arquivos kicad (91.1 kB) Paulo Sérgio Müller, 05/01/2016 01:19

kicad1.png - exportação de gbr kicad (167.9 kB) Paulo Sérgio Müller, 05/01/2016 01:28

kicad2.png - exportação de drl kicad (82.4 kB) Paulo Sérgio Müller, 05/01/2016 01:28

flatcam9.png (114.9 kB) Paulo Sérgio Müller, 05/01/2016 01:37

flatcam0.png - configuracao inicial flatcam (60.2 kB) Paulo Sérgio Müller, 05/01/2016 01:37

flatcam1.png (106.4 kB) Paulo Sérgio Müller, 05/01/2016 01:37

flatcam2.png (121.4 kB) Paulo Sérgio Müller, 05/01/2016 01:37

flatcam3.png (59.9 kB) Paulo Sérgio Müller, 05/01/2016 01:37

flatcam4.png (60.5 kB) Paulo Sérgio Müller, 05/01/2016 01:37

flatcam5.png (56.6 kB) Paulo Sérgio Müller, 05/01/2016 01:37

flatcam6.png (99.5 kB) Paulo Sérgio Müller, 05/01/2016 01:37

flatcam7.png (44.4 kB) Paulo Sérgio Müller, 05/01/2016 01:37

flatcam8.png (37.5 kB) Paulo Sérgio Müller, 05/01/2016 01:37

flatcam11.png (69.9 kB) Paulo Sérgio Müller, 05/01/2016 02:03

flatcam12.png (80.4 kB) Paulo Sérgio Müller, 05/01/2016 02:03

flatcam13.png (101.5 kB) Paulo Sérgio Müller, 05/01/2016 02:03

flatcam14.png (83.8 kB) Paulo Sérgio Müller, 05/01/2016 02:03

flatcam15.png (6.2 kB) Paulo Sérgio Müller, 05/01/2016 02:03

gcode0.png (39.5 kB) Paulo Sérgio Müller, 05/01/2016 02:03

flatcam9.png (114.9 kB) Paulo Sérgio Müller, 06/01/2016 13:40

flatcam10.png (138.2 kB) Paulo Sérgio Müller, 06/01/2016 13:40

kicad3.png (6.6 kB) Paulo Sérgio Müller, 06/01/2016 13:42

kicad10.png (8.9 kB) Alisson Claudino, 24/06/2017 13:14