Documentação para gerar os arquivos digitais para sua fresadora

Esta documentação parte do princípio de que dispões dos arquivos gerber e excellon da placa, disponíveis nesta tarefa. O fluxo de ações necessárias tem como objetivo ser genérico para as diferentes fresadoras, mas as instruções específicas serão para a fresadora hardware aberto e livre João-de-Barro. É importante atentar para detalhes específicos de funcionamento da fresadora que estás usando, que podem alterar - provavelmente de maneira sutil - as instruções contidas nesta página.

Abaixo estão listadas as etapas do processo.


Baixar e executar o programa FlatCAM

Caso já disponhas do programa em teu computador, podes ignorar esta parte das instruções, executar o programa, e seguir para a próxima etapa.

Vá no site do projeto em:

- http://flatcam.org/download

E verifique o comando a ser executado para realizar o download. No caso:

Então rode o script setup_ubuntu.sh dentro da pasta baixada:

  • ./setup_ubuntu.sh

Caso não funcione, verifique o manual de instalação do FlatCAM.

Por fim, execute o programa:

  • python FlatCAM.py

Se não constar este arquivo FlatCAM.py na pasta, uma sugestão é baixar uma versão mais antiga e estável, que contenha o arquivo. Atualmente, de que tenho ciência, a versão mais recente sem este problema é a 8.5, basta baixá-la por aqui.


Importar arquivos de desenho do projeto

Antes de importar os arquivos do projeto, verifique na aba de Options (Opções) na barra lateral esquerda se o programa está configurado para milímetros. Se não estiver, faça a alteração para que esteja.

Então vá na aba superior de File (Arquivo) e importe os arquivos de desenho do projeto em Open Excellon (Abrir Excellon, formato de arquivos de furação) e Open Gerber (Abrir Gerber, formato de arquivo para desenho das camadas).

A sugestão de ordem a se importar os arquivos é a seguinte:

  1. Arquivo dos furos .drl (Excellon)
  2. Arquivo da camada inferiora .grb (Gerber)
  3. Arquivo de reta de alinhamento .grb (Gerber)
  4. Arquivo da camada superiora .grb (Gerber)
  5. Arquivo dos desenhos e escrituras da face superiora .grb (Gerber)
  6. Arquivo de recorte da placa (Geber)

E tem como objetivo organizar o fluxo de ações a partir de agora.

Então, salve um arquivo de projeto na aba File em Save Project (Salvar Projeto). Uma sugestão é escolher uma extensão que te ajude a identificar este arquivo no meio de outros, como fcam.


Espelhamento dos arquivos da face inferiora

Como faremos as furações e a fresa da face inferiora na primeira etapa de usinagem, teremos de espelhá-las para que estejam alinhadas com o outro lado quando fizermos a inversão da placa. É um pouco complexo logicamente, mas com um pouco de observação e prática é possível entender.

Portanto, na barra superiora selecione a aba Tool (Ferramenta) e nela o item Double-Sided PCB Tool (Ferramenta de PCI de dupla face).

Então, na barra lateral abrirá uma janela na qual se deve selecionar os arquivos das camadas inferiores. Selecione o arquivo de furações. Então selecione o eixo a partir do qual se deve espelhar no item Mirror Axis (Eixo de espelhamento), que será o eixo paralelo ao qual a reta de alinhamento estará, que no caso é o eixo y.

No próximo item, Axis Location (Localização do Eixo), selecione Box (Caixa) e na linha de seleção que aparece em Point/Box (Ponto/Caixa) escolha o arquivo com a reta de alinhamento.

Por fim, é só clicar no botão Mirror Object (Espelhar Objeto) e o arquivo/objeto estará espelhado, o que pode ser conferido na janela gráfica.

Basta repetir o procedimento para o arquivo de fresa da face inferiora e o espelhamento estará concluído.


Aplicar desvio nas camadas dos arquivos de fresa

Dependendo da fresadora utilizada, pode ser interessante aplicar um pequeno desvio em x e em y para eliminar imprecisões nos limites da área de trabalho da fresadora. Na João-de-Barro Pro até agora foi usado um desvio de 1,0 mm em x e em y. Para tanto, seleciona cada um dos arquivos na barra lateral e na aba Selected (Selecionado), vá até o final desta aba, e aplique o Offset (Desvio) na forma de vetor. Para a Fresadora João-de-Barro pasta preencher o campo Vector (Vetor) com o seguinte vetor:

  • (1.0, 1.0)

Confira o valor adequado para a tua fresadora. Então repita este processo para todos os arquivos.


Gerar os códigos g dos arquivos de furação

Começaremos trabalhando com o arquivo de furação: selecione-o na barra lateral.

Então clique duas vezes no mesmo ou vá na aba Selected (Selecionado), lá deve aparecer uma lista de furações de diferentes diâmetros.

Furações de 0.8 mm

Nesta lista, selecione aquelas de menor espessura que podem ser agrupadas em um conjunto furado pela mesma broca. No caso da placa EMM Memória é de 0.8 mm, na qual se devem agrupar os furos de 0.762 mm, os de 0.8 mm e os de 0.813 mm. Nos itens abaixo, deves selecionar os parâmetros para furação:

  • Cut z (Corte em z) é a altura até a qual a ferramenta usinará em z. É expressa em milímetros.
  • Travel z (Viagem em z) é a altura em z na qual a ferramenta viajará entre uma furação e outra ou uma fresa e outra. É expressa em milímetros.
  • Feed rate (Taxa de alimentação) é a taxa com que a ferramenta avança, dada em milímetros por minuto.
  • Spindle speed (Velocidade do spindle) é a velocidade com que a ferramenta gira. Não é ajustável com a João-de-Barro.
Para a João-de-Barro Pro, selecione as seguintes configurações (confira as configurações para a sua máquina):
  • Cut z = 15.0
  • Travel z = 11.5
  • Feed rate = 400.0

Então gere a geometria, que deverá aparecer visualmente na tela, e corresponde a um arquivo CNC drill (furo CNC), a partir do qual se pode gerar os códigos g.

Furações de 1.0 mm

Para facilitar a visualização, vá nos arquivos de fresa da face inferiora e superiora e no arquivo da reta de alinhamento, selecione-os e desmarque a opção plot (exibir em um gráfico).

Então selecione o segundo conjunto, que neste caso é o de 1.0 mm. Selecione os grupos de 1.0 mm, de 1.001 mm e de 1.016 mm, mas deixe de fora os furos de 1.012 mm, que são os furos de alinhamento, estes devem estar em arquivos separados.

Para a João-de-Barro Pro, selecione as mesmas configurações (confira as configurações para a sua máquina):
  • Cut z = 15.0
  • Travel z = 11.5
  • Feed rate = 400.0

E gere o arquivo furo CNC.

Furações de alinhamento

Selecione então estes furos de 1.012 mm e gere um arquivo à parte, com broca de 1.0 mm mesmo.

Para a João-de-Barro Pro, selecione as seguintes configurações (confira as configurações para a sua máquina):
  • Cut z = 18.5
  • Travel z = 11.5
  • Feed rate = 400.0

E gere o arquivo furo CNC. A profundidade maior nesse caso se dá para que se possa firmar um pino de alinhamento posteriormente.

Furações de 1.2 mm

O quarto conjunto é o de 1.2 mm, que agrupa o grupo 1.349 mm.

Para a João-de-Barro Pro, selecione as configurações padrão de furação (confira as configurações para a sua máquina):
  • Cut z = 15.0
  • Travel z = 11.5
  • Feed rate = 400.0

Lembre de retornar o Cut z para 15.0 mm. E gere o arquivo furo CNC.

Furações de 1.5 mm

O quinto é o de 1.5 mm, com os grupo de 1.524 mm.

Para a João-de-Barro Pro, selecione as mesmas configurações (confira as configurações para a sua máquina):
  • Cut z = 15.0
  • Travel z = 11.5
  • Feed rate = 400.0

E gere o arquivo furo CNC.

Furações de 2.0 mm

E por fim os de 2.0 mm, com o grupo de 2.0 mm.

Para a João-de-Barro Pro, selecione as mesmas configurações (confira as configurações para a sua máquina):
  • Cut z = 15.0
  • Travel z = 11.5
  • Feed rate = 400.0

E gere o arquivo furo CNC.

Gerar e salvar códigos g

Então, voltando para a aba Project é possível encontrar estes novos arquivos. Selecione cada um deles na ordem estabelecida e na aba Selected gere o arquivo de código g para cada um dos conjuntos.

Antes de gerar o arquivo código g, podes querer observar com mais clareza a geometria, então preencha o campo Tool dia (diâmetro da Ferramenta) com o diâmetro da ferramenta em questão e aperte o botão Upload Plot (Atualizar gráfico).

Depois aperte o botão Export G-Code (Exportar Código G). Neste momento, se abrirá uma janela para salvar os arquivos. Crie uma pasta (a sugestão de nome é "NGC", extensão dos arquivos de cógido g) dentro da pasta onde se encontram os arquivos Gerber e Excellon do projeto, e nela salve os arquivos de códigos g.

O padrão de nome sugerido para os arquivos é o seguinte:

  • "face"_"tipo de usinagem"_"diâmetro da ferramenta"_"altura da usinagem na coordenada z".ngc
  • A face pode ser 01 (inferiora) ou 02 (superiora).
  • O tipo de usinagem pode ser furo ou fresa.
  • O diâmetro da fresa é expresso sem pontos, ou seja, 1.5 mm equivale a "15".
  • A altura de usinagem na coordenada z é a altura até a qual se pretende furar ou cortar, por exemplo a mesa ou a placa, e é representada em milímetros com pontos seguidos de letra que indica o tipo de superfície ("p" de placa ou "m" de mesa), ou seja, um furo na superíficie da mesa a 15 milímetros é indicada por "15m".

Então, para a placa das EMM, os arquivos de furos gerados terão a seguinte indicação:

  1. 01_furo_08_15m.ngc
  2. 01_furo_10_15m.ngc
  3. 01_furo_10_alinha_15m.ngc
  4. 01_furo_12_15m.ngc
  5. 01_furo_15_15m.ngc
  6. 01_furo_20_15m.ngc

O arquivo dos furos de alinhamento conta com as indicações "alinha" para mais fácil identificação.


Gerar códigos g de fresa da face inferiora

Agora vamos trabalhar com a fresa da face inferiora. Desmarque a opção Plot em todos os arquivos furo cnc, para melhorar a visualização.

Selecione o arquivo da fresa da face inferiora na barra lateral esquerda e marque a opção Plot.

No menu que se abre, aparecem as seguintes configurações:

  • Tool dia (diâmetro da Ferramenta)
  • Width (# passes) (Largura, número de passadas)
  • Pass overlap (sobreposição de passadas)

Selecione e configure da seguinte maneira:

  • 0.5
  • 3
  • 0.3
  • Marque Combine Passes (Combinar Passos)

Escolhemos assim, pois se atinge um bom resultado com três passadas da fresa, cada uma sobrepondo 30% do trajeto da passada anterior. A marcação de combinar os passos, serve para que só um arquivo seja gerado para as três passadas, o que evita que se acumulem muitos arquivos na barra lateral. Para esta etapa da usinagem em específico, selecionamos o diâmetro de ferramenta de 0.5 mm, que vem sendo usado na João-de-Barro para fresas de 20 graus e cortes de 0.1 mm de profundidade.

Gere o arquivo intermediário com o botão Generate Geometry (Gerar Geometria).

Neste momento é possível conferir se as configurações ficaram boas por meio da janela gráfica. É importante conferir especialmente se for a primeira ou uma das primeiras vezes em que estiveres fresando uma determinada placa. Neste caso, já estamos tranquilos e seguros.

Então, selecione o arquivo da geometria gerada

Para a João-de-Barro Pro, selecione as seguintes configurações (confira as configurações para a tua máquina):

  • Cut z: 13.1
  • Travel z: 11.5
  • Feed rate: 300.0
  • Tool dia: 0.5

O corte em z é menos profundo agora pois só estaremos isolando o cobre, ou seja, estaremos cortando em uma profundidade um pouco abaixo da superfície, e não até o outro lado da placa, na mesa. A taxa de alimentação também é reduzida, pois esse é um procedimento mais delicado do que furar, para o qual simplesmente se atravessa a placa. Neste caso, estaremos cortando cobre, o que apresenta mais resistência à ferramenta.

Com isso, podemos gerar o trabalho CNC no botão Generate.

!imagem do trabalho CNC gerado!

Neste arquivo, gere o código g, o qual se salva com a seguinte indicação:

  • 01_fresa_05_13p.ngc

Esse é o nome, pois continuaremos na mesma face e estaremos fresando ao invés de furar nesse caso. O "05" indica 0.5 mm e é utilizado com sucesso para fresas em "V" de 20 graus. Para conferir quanto seria de fato o diâmetro, seria indicado fazer um cálculo a partir de triângulos e de algumas considerações, mas para a João-de-Barro Pro tem funcionado bem este valor. Por fim, estaremos fazendo o alinhamento na placa e não na mesa, e portanto em 13.0 mm e não em 15.0 mm, o que resulta em "13p".


Gerar códigos g de fresa da face superiora

Agora vamos trabalhar com a face superiora. Desmarque a opção Plot de todos os arquivos da fresa da face inferiora e também do arquivo dos furos.

Selecione o arquivo da fresa da face superiora na barra lateral e marque a opção Plot.

Novamente, selecione:

  • Tool dia: 0.5
  • Width (#passes): 3
  • Pass overlap: 0.3
  • Marque Combine Passes (Combinar Passos)

E gere a geometria.

Então, para a João-de-Barro Pro, selecione as seguintes configurações (confira as configurações para a tua máquina):

  • Cut z: 13.1
  • Travel z: 11.5
  • Feed rate: 300.0
  • Tool dia: 0.5

Que são as mesmas da face inferiora, pois realmente se deseja obter as mesmas características. Podemos então gerar o trabalho CNC.

A partir da geometria podemos gerar o código, que salvamos com a seguine indicação:

  • 02_fresa_05_13p.ngc

O que mantém quase todas os códigos do arquivo anterior, pois realmente a única coisa que muda é a face na qual se está trabalhando.


Gerar códigos g de remoção do cobre

Retornando para o arquivo original da fresa da face superiora, vamos até o menu de Non-copper regions (regiões de não-cobre).

Nele, selecionamos a distância a partir da borda que pretendemos gerar a geometria no campo Boundary Margin (Margem da Borda):

  • 1.8
  • Marcar a opção Rounded corners (cantos Arredondados)

E geramos a geometria.

Então, para a geometria gerada, vamos até o menu de Paint area (pintar área).

Para os campos Tool dia, Overlap e Margin selecionamos as seguintes configurações respectivamente:

  • 1.6
  • 0.1
  • 0.3
  • No campo Method (Método), marcar a opção Seed based (baseado em semente)

Apertamos o botão Generate para gerar a geometria.

E então clicamos dentro do polígono, que é o retângulo gerado no passo anterior com o recorte da borda.

Neste passo, o programa deve demorar um pouco, pois está gerando um arquivo pesado com coordenadas circulares que cobrem toda a parte da face superiora sem trilhas.

Quando este arquivo aparecer selecionamos ele.

E, para a João-de-Barro Pro, definimos as seguintes configurações:

  • Cut z: 13.1
  • Travel z: 11.5
  • Feed rate: 100.0
  • Tool dia: 1.6

Neste caso, estamos trabalhando com uma taxa de alimentação mais baixa, pois estamos trabalhando com uma ferramenta mais grossa, que tem como objetivo retirar cobre sem deixar rebarbas, cobrindo o máximo de área por vez, e que, por isso, enfrenta mais resistência do material.

Então geramos o trabalho CNC, e a partir dele o código g, com a seguinte indicação:

  • 02_fresa_16_13p.ngc

Pois estamos trabalhando na face superiora, com uma fresa mais grossa, de 1.6 mm, com alinhamento na placa a 13.0 mm.


Gerar códigos g de escritas

Desmarque a opção Plot de todos os arquivos da face superiora, de isolamento das trilhas e de remoção do cobre.

Vamos trabalhar com o arquivo das escritas, então selecionamos ele.

Definimos as seguintes configurações:

  • Tool dia: 0.3
  • Width (#passes): 1
  • Pass overlap: 0.15
  • Marque Combine Passes (Combinar Passos)

Neste caso, como as escrituras são muito finas, fazemos uma passada só, para não gerar confusão nas letras, e porque tecnicamente não queremos isolar nada, apenas visualmente queremos passar uma mensagem. A seleção de 15 % é a padrão, e podemos deixá-la pois alterar seria inócuo, pois faremos apenas uma passada.

Geramos a geometria.

Então, com a geometria gerada, para a João-de-Barro Pro, definimos as seguintes configurações:

  • Cut z: 13.2
  • Travel z: 11.5
  • Feed rate: 300.0
  • Tool dia: 0.3

O fato de estarmos cortando em 13.2 mm é porque já removemos todo o cobre, então uma camada de 0.1 mm abaixo da superfície já foi retirada, portanto temos de aprofundar em 0.1 mm para gravarmos as indicações.

A partir do trabalho CNC gerado, podemos gerar o código g com a seguinte indicação:

  • 02_fresa_03_13.1p.ngc

Pois seguimos na mesma face, com uma fresa agora ainda mais fina, porque queremos boa definição da escrita. E desta vez com um alinhamento em 13.1 mm na placa, pois já removemos a primeira a camada, e estaremos alinhando sobre a fibra vidro.


Gerar códigos g de recorte da placa

Faremos a última etapa agora, de recorte da placa, então demarcamos a opção Plot em todos os arquivos de escrita e selecionamos o arquivo de recorte da placa.

Poderíamos trabalhar com o menu de recorte de borda, que usamos na etapa de remoção de cobre, mas como não se trata de uma borda retangular, ou seja, o polígono não é um quadrilátero, essa função não funciona.

Então, trabalhamos no primeiro menu, como para as trilhas, pois as bordas serão tratadas como trilhas, e configuramos da seguinte maneira:

  • Tool dia: 2.0
  • Width (#passes): 1
  • Pass overlap: 0.15
  • Marque Combine Passes (Combinar Passos)

Novamente, não precisamos de mais de uma passada, então por isso a sobreposição pode ser deixada como padrão. Neste caso, não precisamos de mais de uma passada, pois só precisamos cortar de forma a destacar a placa, sem necessidade de precisão boa ou detalhes bem acabados.

Geramos a geometria.

Com a geometria gerada, selecionamos as seguintes configurações para a João-de-Barro Pro (verifique as configurações para a tua máquina):

  • Cut z: 15.0
  • Travel z: 11.5
  • Feed rate: 60.0
  • Tool dia: 2.0

Como estaremos recortando a placa, precisamos ir até a outra extremidade, na profundidade de 15.0 mm. E por este mesmo motivo, de estarmos fresando a uma profundidade grande, de 2.0 mm, com uma ferramenta grossa, os fatores se somam para oferecer resistência à ferramenta, o que embasa a escolha de uma taxa de alimentação bem baixa.

Geramos o arquivo de trabalho CNC.

Selecionando o trabalho CNC, podemos gerar o último código g com a seguinte indicação

  • 02_fresa_20_15m.ngc

Pois estamos na mesma face, fresando com a ferramenta mais espessa, e agora realizaremos o alinhamento na mesa, pois é até essa profundidade que queremos cortar.

Então geramos o código g derradeiro.

Com isso, concluímos a geração do último código g, e podemos então seguir para a etapa da Documentação para fresar a placa.


Dicas extras:

  • Em alguns momentos, se a furação não atravessa a placa, deixando uma camada de cobre suficientemente grossa em um dos lados, a ponto de ficar chato de tirar, é possível realizar o seguinte procedimento: Importe novamente os arquivos Excellon de furação e gere os códigos g sem realizar o espelhamento. Basta seguir novamente os passos na etapa Gerar os códigos g dos arquivos de furação, ignorando as indicações da etapa Espelhamento dos arquivos da face inferiora. A usinagem destes arquivos pode ser feita em qualquer etapa a partir do momento em que a placa for invertida e antes da placa ser recortada.
  • Se alguma dúvida persistir, cabe conferir a Documentação de Uso/Manual João-de-Barro, tendo em mente que as orientações lá são genéricas em termos de placa, enquanto as aqui descritas são para a placa de controle das EMM especificamente.